Belvo recurrent links are experiencing errors fetching data
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 12:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2024 - 12:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2024 - 12:32 UTC
Investigating
Currently we are not able to fetch data from some institutions due to some credential issues.
Posted Jun 26, 2024 - 12:23 UTC
This incident affected: Recurrent Links.