Link creation on institution bancomer_mx_retail is showing high error rates
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 16:27 UTC
Investigating
We are currently investigating this issue. Please note that operations on existing links should not be affected.
Posted Apr 09, 2021 - 17:51 UTC
This incident affected: API and Widget.