Cloudflare Global Network experiencing issues

Incident Report for Belvo

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:03 UTC

Monitoring

A workaround has been applied, and we are monitoring the results
Posted Nov 18, 2025 - 13:56 UTC

Identified

Belvo is currently suffering an outage due to a global outage of CloudFlare.

For more information: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 13:09 UTC
This incident affected: 🇧🇷 Payments BR (API, Biometric Pix Widget (JSR), Dashboard, Payment Link / Widget, Webhooks).