We have detected an error response spike when retrieving information from institutions
Incident Report for Belvo Technologies
Resolved
All systems are back to normal now.

We are closing this incident, sorry for the inconvenience.
Posted Jul 31, 2020 - 15:43 UTC
Monitoring
We have applied a fix for this issue, we will continue monitoring.
Posted Jul 31, 2020 - 15:22 UTC
Investigating
We are currently investigating the issue
Posted Jul 31, 2020 - 14:55 UTC
This incident affected: API.