Banco Inter deactivated

Incident Report for Belvo

Resolved

The incident has been resolved. Banco Inter Business has been activated again.
Posted Sep 26, 2025 - 14:46 UTC

Investigating

Technical issues with the institution
Posted Sep 25, 2025 - 08:54 UTC
This incident affected: Data Aggregation (API, Widget).