High error rates on api.belvo.com
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 18:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2021 - 17:54 UTC
This incident affected: API, Widget, and Dashboard.