Data Processing Delays - Data retrieval delays
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Jun 18, 2022 - 07:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 18, 2022 - 07:31 UTC
Monitoring
Our data processing infrastructure is running behind
Posted Jun 18, 2022 - 06:49 UTC
This incident affected: API, Widget, Webhooks, Dashboard, Recurrent Links, Sandbox environment, and Development environment.