Belvo API service is currently experiencing issues where some requests are failing to process
Incident Report for Belvo
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 08:20 UTC
Monitoring
A fix has been implementing and we are monitoring it
Posted Sep 27, 2024 - 08:09 UTC
Investigating
When the widget is trying to create a link the Public API is returning 50x errors
Posted Sep 27, 2024 - 05:17 UTC
This incident affected: Data Aggregation (API, Widget).