Belvo API, Belvo historical and Belvo recurrent are experiencing errors fetching data
Incident Report for Belvo
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 13:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 09, 2024 - 12:45 UTC
Investigating
We are currently investigating this issue.
Posted Jul 09, 2024 - 12:30 UTC
This incident affected: Data Aggregation (API, Recurrent Links).