High error rate in Public API returning 502 errors
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 23:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2024 - 23:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 14, 2024 - 22:31 UTC
This incident affected: API.