GET calls and recurrent links are experiencing a slightly higher error rate

Incident Report for Belvo

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 07:19 UTC

Investigating

We are currently investigating this issue.
Posted Apr 29, 2025 - 06:23 UTC
This incident affected: Data Aggregation (API, Recurrent Links).