Public API is experiencing degraded performance and some requests are failing
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 14:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2024 - 13:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 05, 2024 - 13:50 UTC
Investigating
We are currently investigating this issue.
Posted Apr 05, 2024 - 13:40 UTC
This incident affected: API.