We are experiencing a high volume of errors in OpenFinance Institutions
Incident Report for Belvo Technologies
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 06:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2024 - 06:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 28, 2024 - 06:44 UTC
Investigating
We are investigating the issue
Posted Jun 28, 2024 - 05:25 UTC
This incident affected: Recurrent Links.