Some users are unable to check activity logs
Incident Report for Belvo Technologies
Resolved
This issue has been fixed in our latest dashboard release, please be sure to clear your browser cache and reload.
Posted Jun 18, 2020 - 12:36 UTC
Monitoring
We have released a new version of our dashboard to solve this issue. Please be sure you clean your browser cache and reload.
Posted Jun 18, 2020 - 12:12 UTC
Investigating
We are currently investigating this issue.
Posted Jun 18, 2020 - 10:28 UTC
Monitoring
We have deployed fix for this issue. Users don't need to take any actions on their side.
Posted Jun 18, 2020 - 07:50 UTC
Identified
We have received reports from a limited number of users that they are not able to see activity logs, the root cause of the error has been identified and we are currently working on fixing it.

Only activity logs are affected and the rest of the dashboard features remain functional.
Posted Jun 17, 2020 - 16:56 UTC
This incident affected: Dashboard.