Partial API degradation

Incident Report for Belvo

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 07:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2025 - 00:40 UTC

Investigating

GET requests to employment-records are out of service
Posted Apr 09, 2025 - 21:26 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 09, 2025 - 18:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2025 - 18:43 UTC

Identified

The database is currently under high stress affecting all API endpoints, increasing latency and error rates.
Posted Apr 09, 2025 - 18:20 UTC
This incident affected: Data Aggregation (API, Belvo Connect Pages, Dashboard, Recurrent Links).